Andrew Latham

I was working on https://github.com/lathama/Adynaton and playing with pylint for linting. One common issue I see is the naming conflicts. PEP8 has good guidance on naming and when dealing with abbreviations. So when using DNS for Domain Name System it is proper to use the uppercase abbreviation. Elsewhere in the guidelines the recommendation that abbreviations not be used when possible and to be very descriptive. So when a linter says that a variable name is not valid like self.DNS_port it is sort of frustrating to know that the results will be skewed. I understand that self.domain_name_system_port is descriptive and that inferring the class name is the defined way to go. My concern is with legacy code that might exist with acceptable usage of naming conventions but linters fail the developers attempting to improve their code. Lets not lower the standards of linters but instead offer a legacy switch to enable developers to benefit first from the serious issues before getting into the fine details.